Homeworld 2 Complex Forum Index
 Portal •  Blog •  Album •  FAQ  •  Search  •  Memberlist  •  Usergroups   •  Calendar   •  Register  •  User Panel  •  Log in to check your private messages  •  Log in
  FlashChat  •  Statistics  •  Links  •   Downloads  •   Comments to your karma  •  Toplist  •  Guestbook  •  Recent topics  •  Voting forum
Crash to desktop upon launch
Users browsing this topic:0 Registered, 0 Hidden and 0 Guests
Registered Users: None

Goto page Previous  1, 2
 
Post new topic   Reply to topic    Homeworld 2 Complex Forum Index -> General
View previous topicEmail to a Friend.Users who have viewed this topicSave this topic as a txt filePrintable versionLog in to check your private messagesView next topic
Author Message
Oni

Lead Artist
Lead Artist


Complex Team

Gender: Gender:Male

Joined: 26 Jan 2009
Posts: 1353
Oni is offline 

Location: Czech





czechrepublic
PostPosted: Wed Jan 18, 2017 10:57 pm    Post subject:  
Description:
Reply with quote

Maibe it is not graphic problem, it requires more informations.
If you have Steam you simple click the subscribe button, then the mod is downloaded. once it is done you open the homeworld mod manager from steam and select the complex 10 (only).
Click launch button and everything should work.
If not there must be 3rd party content or DLC causing the crash.
Back to top
View user's profile Send private message
hiig

Ensign
Ensign




Gender: Gender:Male

Joined: 12 Jan 2017
Posts: 8
hiig is offline 







australia
PostPosted: Fri Jan 20, 2017 11:45 am    Post subject:  
Description:
Reply with quote

Oni wrote:
Maibe it is not graphic problem, it requires more informations.
If you have Steam you simple click the subscribe button, then the mod is downloaded. once it is done you open the homeworld mod manager from steam and select the complex 10 (only).
Click launch button and everything should work.
If not there must be 3rd party content or DLC causing the crash.


There must be. I can't see any other reason as to why I can't remove those campaign commands to let Complex work. I don't suppose there is some sort of command to add in the shortcut that instructs the program to ignore all previous commands? I'm guessing that would fix the issue.
Back to top
View user's profile Send private message
Dwayne

Ensign
Ensign





Age: 29
Joined: 21 Jul 2008
Posts: 2
Dwayne is offline 






PostPosted: Sat Jan 21, 2017 4:55 pm    Post subject:  
Description:
Reply with quote

Just to make sure, because complex did run only on patched version of original Homeworld2.
Do you need to patch HW Remastered in order to complex actually work ? I did tried version 1.2 and 1.24, no luck in both of them.
And i dont run Steam version of the game
Back to top
View user's profile Send private message
vees0ei

Ensign
Ensign






Joined: 24 Jan 2017
Posts: 1
vees0ei is offline 







italy
PostPosted: Tue Jan 24, 2017 10:38 pm    Post subject:  
Description:
Reply with quote

I am experiencing the same issue, HWRM crashes right before the main menu is to be displayed

Looking at the already posted crashdump:

0(2Cool : error C7532: global function texture requires "#version 130" or later
0(26) : error C7502: OpenGL does not allow type suffix 'f' on constant literals in versions below 120
0(2Cool : error C7532: global function texture requires "#version 130" or later

This seems to indicate that a minimum patchlevel for the mod to work could we get any dev feedback on this?
Back to top
View user's profile Send private message
Oni

Lead Artist
Lead Artist


Complex Team

Gender: Gender:Male

Joined: 26 Jan 2009
Posts: 1353
Oni is offline 

Location: Czech





czechrepublic
PostPosted: Wed Jan 25, 2017 3:13 pm    Post subject:  
Description:
Reply with quote

You must have steam version with latest hwrm patch.
Back to top
View user's profile Send private message
qtfdfdxp

Ensign
Ensign






Joined: 28 Jan 2017
Posts: 1
qtfdfdxp is offline 







italy
PostPosted: Sat Jan 28, 2017 5:34 pm    Post subject:  
Description:
Reply with quote

[quote="Oni"]You must have steam version with latest hwrm patch.[/quote]

Please clarify? I must have the *steam version*, the *retail version* does not work, even at full patchlevel?
Back to top
View user's profile Send private message
Oni

Lead Artist
Lead Artist


Complex Team

Gender: Gender:Male

Joined: 26 Jan 2009
Posts: 1353
Oni is offline 

Location: Czech





czechrepublic
PostPosted: Sat Jan 28, 2017 7:01 pm    Post subject:  
Description:
Reply with quote

I don't know what is in retail version but you should have at least patch 2.0
Back to top
View user's profile Send private message
Bastard2k

Ensign
Ensign






Joined: 05 Aug 2017
Posts: 3
Bastard2k is offline 







canada
PostPosted: Sat Aug 05, 2017 3:28 pm    Post subject:  
Description:
Reply with quote

Im running 2.01 and getting same issue.

Sat Aug 05 10:17:00 2017
Version 1.28, Build Number 10, Changelist Number 1057918
Loaded Archive: 'Homeworld2.big'
Loaded Archive: 'UpdateHomeworld2.big'
Loaded Archive: 'HW1Ships.big'
Loaded Archive: 'UpdateHW1Ships.big'
Loaded Archive: 'HW2Ships.big'
Loaded Archive: 'UpdateHW2Ships.big'
Loaded Archive: 'HWBackgrounds.big'
Loaded Archive: 'UpdateHWBackgrounds.big'
Loaded Archive: 'English.big'
Loaded Archive: 'UpdateEnglish.big'
Loaded Archive: 'Compatibility.big'
Loaded Archive: 'Complex1057.big'
Uing ..profiles\ for profiles folder
keybinding Salvage/Capture field '2' is missing, setting to min
keybinding $5472 field '2' is missing, setting to min
keybinding $5474 field '2' is missing, setting to min
keybinding $5473 field '2' is missing, setting to min
keybinding $5520 field '2' is missing, setting to min
keybinding $5521 field '2' is missing, setting to min
GAME -- Using player profile Btard
Changing from a 32 bit colour depth in winNT (6.2 build 9200),
Display: (0, 0, 1920, 1080) - (0, 0)
Display: (0, 0, 1920, 1080) - (0, 0)
Switching to a 1920x1080 32bit mode
GL Info: 3.3 - 3.3.0 NVIDIA 384.94
GL Vendor: NVIDIA Corporation
GL Renderer: GeForce GTX 980 Ti/PCIe/SSE2
GL Part ID: 980
sob_badge - FRAG
0(819) : error C1008: undefined variable "getShipExp"
sob_badge_glow - FRAG
0(820) : error C1008: undefined variable "getShipExp"
sob_bay - FRAG
0(823) : error C1008: undefined variable "getShipExp"
0(826) : error C1008: undefined variable "getBayExp"
sob_matte - FRAG
0(725) : error C1008: undefined variable "getShipExp"
sob_matte_a - FRAG
0(726) : error C1008: undefined variable "getShipExp"
sob_matte_s - FRAG
0(726) : error C1008: undefined variable "getShipExp"
sob_matte2s - FRAG
0(726) : error C1008: undefined variable "getShipExp"
sob_matte2s_a - FRAG
0(727) : error C1008: undefined variable "getShipExp"
sob_matte2s_s - FRAG
0(727) : error C1008: undefined variable "getShipExp"
sob_ore - FRAG
0(726) : error C1008: undefined variable "getShipExp"
sob_salvage - FRAG
0(727) : error C1008: undefined variable "getShipExp"
sob_ship - FRAG
0(818) : error C1008: undefined variable "getShipExp"
sob_ship_glow - FRAG
0(819) : error C1008: undefined variable "getShipExp"
sob_thruster - FRAG
0(819) : error C1008: undefined variable "getShipExp"
fx_eng_burnbasic - FRAG
0(1) : warning C7022: unrecognized profile specifier "smooth"
0(1) : error C0502: syntax error at token "smooth"
0(2) : warning C7022: unrecognized profile specifier "smooth"
0(2) : error C0502: syntax error at token "smooth"
0(6) : error C0000: syntax error, unexpected '(', expecting "::" at token "("
0(2Cool : error C7532: global function texture requires "#version 130" or later
fx_eng_trailbasic - FRAG
0(1) : warning C7022: unrecognized profile specifier "smooth"
0(1) : error C0502: syntax error at token "smooth"
0(2) : warning C7022: unrecognized profile specifier "smooth"
0(2) : error C0502: syntax error at token "smooth"
0(3) : warning C7022: unrecognized profile specifier "smooth"
0(3) : error C0502: syntax error at token "smooth"
0(10) : error C0000: syntax error, unexpected '(', expecting "::" at token "("
0(26) : error C7502: OpenGL does not allow type suffix 'f' on constant literals in versions below 120
0(2Cool : error C7532: global function texture requires "#version 130" or later
fx_debris - FRAG
0(732) : error C1008: undefined variable "getShipExp"
sob_oni_shipwreck - FRAG
0(805) : error C1008: undefined variable "getShipExp"
sob_oni_salvage - FRAG
0(712) : error C1008: undefined variable "getShipExp"
Loaded Archive: 'EnglishSpeech.big'
Loaded Archive: 'UpdateEnglishSpeech.big'
Loaded Archive: 'Music.big'
Loaded Archive: 'UpdateMusic.big'
SOUND -- created destination [ fdaudio ], handle [ 4 ] with [ 48 ] channels created
SOUND -- created destination [ fda streamer ], handle [ 5 ] with [ 8 ] channels created
SOUND -- created destination [ dxa streamer ], handle [ 0 ] with [ 8 ] channels created
SOUND -- created destination [ dxaudio ], handle [ 1 ] with [ 48 ] channels created
Build name:
Built by : builduser
Data path : C:\Games\Homeworld Remastered Collection\HomeworldRM\data
Style DefaultContextMenuStyle of type ContextMenu does not exist in stylesheet
Back to top
View user's profile Send private message AIM Address
Oni

Lead Artist
Lead Artist


Complex Team

Gender: Gender:Male

Joined: 26 Jan 2009
Posts: 1353
Oni is offline 

Location: Czech





czechrepublic
PostPosted: Sat Aug 05, 2017 4:57 pm    Post subject:  
Description:
Reply with quote

It looks like your graphic card have some extra fueatures for improving graphics in games.
But HWRM simple does not like it.
Try to lower or disablle some post process features in your GPU settings.
Back to top
View user's profile Send private message
Bastard2k

Ensign
Ensign






Joined: 05 Aug 2017
Posts: 3
Bastard2k is offline 







canada
PostPosted: Sun Aug 06, 2017 1:27 am    Post subject:  
Description:
Reply with quote

Its an nvidia 980ti... What do you mean disable features? grapics settings in the game?

Game runs fine. Complex does not.

I tried knocking settings back.. Nothing.

This is a mod bug and im not the only one experiencing the same errors.
Back to top
View user's profile Send private message AIM Address
Oni

Lead Artist
Lead Artist


Complex Team

Gender: Gender:Male

Joined: 26 Jan 2009
Posts: 1353
Oni is offline 

Location: Czech





czechrepublic
PostPosted: Sun Aug 06, 2017 8:42 am    Post subject:  
Description:
Reply with quote

The thing is, it can happen only on certain type of graphic cards.
Else this issue would have everybody.

I mean modern graphic cards can force application to look better even if the application did not support it.
Like SSAO or multiframe anitialiasing etc.
The thing is that, you get error in files that are not part of the mod, speciali graphic shaders config files.

Anyway it is posible you are using updates that affects the mod itself.
I need to know what files you have in:
E:\STEAM\SteamApps\common\Homeworld\HomeworldRM\DataUpdates
You can make a screenshot.

This folder should be empty.
Back to top
View user's profile Send private message
Bastard2k

Ensign
Ensign






Joined: 05 Aug 2017
Posts: 3
Bastard2k is offline 







canada
PostPosted: Sun Aug 06, 2017 2:39 pm    Post subject:  
Description:
Reply with quote

dont have steam version... zero stuff in that folder.

gonna try reinstalling. and not applying the 2.01 patch and see how it goes.
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic    Homeworld 2 Complex Forum Index -> General All times are GMT + 1 Hour
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Homeworld 2 Complex topic RSS feed 
Powered by MasterTopForum Premium with phpBB 2003 - 2009